Summary

  • The 2017.2 update will not finish because of Windows Installer Coordinator
  • My 2017.2 update won't finish
  • The 2017.2 update hangs on the Windows Installer Coordinator part
  • Please wait while the application is preparing for the first time
  • The 2018 installation will not finish because of Windows Installer Coordinator
  • The 2018 install hangs on the Windows Installer Coordinator part
  • The install will not finish because of Windows Installer Coordinator
This solution requires advanced knowledge of your computer's operating system. Contact your system administrator for assistance. Modifying your Windows Registry incorrectly can severely affect system operations. Sage is not responsible for operation issues caused by incorrectly modifying your Windows Registry. Always create a backup of your data before proceeding with advanced solutions.

Cause

  • The RDS Compatibility for the computer has not been enabled
  • Issue has been known to occur on Windows 10, Server 2008 and Server 2012

Resolution

  1. Select Cancel on the error and close out of the update.
  2. Click Start button.
  3. In the Search box type gpedit.msc, and then press Enter.
  4. Select Computer Configuration
  5. Select Administrative Templates.
  6. Select Windows Components.
  7. Select Remote Desktop Services.
  8. Select Remote Desktop Session Host.
  9. Select Application Compatibility
  10. Double-click Turn Off Windows Installer RDS Compatibility, and set it to Enabled
  11. Rerun update/install.
  12. Verify installs without error.